1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Bitte schaltet eure Ad Blocker aus. SLinfo kann nur betrieben werden, wenn es durch Werbung Einnahmen erzielt. Vielen Dank!!
    Information ausblenden
  3. Wir freuen uns, wenn du dich in unserem Forum anmeldest. Bitte beachte, dass die Freigabe per Hand durchgeführt wird (Schutz vor Spammer). Damit kann die Freigabe bis zu 24 Stunden dauern.
    Information ausblenden

Gebäude nicht begehbar

Dieses Thema im Forum "Meshes" wurde erstellt von argus Portal, 27. März 2013.

  1. argus Portal

    argus Portal Freund/in des Forums

    Beiträge:
    875
    Zustimmungen:
    5
    Punkte für Erfolge:
    18
    An der Zugriffs-Anzahl des Threads ist zu erkennen, wie wichtig das Thema "Mesh" für viele ist.

    Ich denke, ich kann jetzt abschliessend etwas bestätigen, das ich vorher schon sagte und auch von anderen höre: Diese Technik ist nicht ausgereift. Natürlich kann man Fehler beim Erstellen von Meshs machen. Aber auch wenn alles korrekt ist, versagt die Technik sporadisch. Mein hier geschildertes Problem mit nicht begehbaren Gebäuden gehört dazu. Der eine lädt es zig mal hoch und es geht nicht, der andere hat sofort Erfolg: Unter denselben Bedingungen

    Aktuell gibt es ein Problem mit der UV-Map. Plötzlich stimmt die Texturierung nicht: Texturanteile sind verschoben.

    Zudem schwankt der Primcount. Gleicher Ort, gleicher Viewer: mehrfach nacheinander upgeloadet = unterschiedliche Resultate.

    Ich habe hier jetzt dreimal ein Gebäude hochgeladen: Das erste ist korrekt. Die beiden anderen haben Probleme mit der UV-Map.

    Wobei die Texturstörungen aber bei beiden verschieden sind.

    Fazit (und Grund für meinen Nachtrag hier) : Sucht nicht immer die Fehler bei euch. Wenn etwas einfach nicht laufen will, ist die Ursache sehr sicher in der bislang vermurksten Software zu suchen. In dem Fall nicht aufgeben: Solange uploaden, bis es "passt". Dumm nur, das es jedesmal Geld kostet. Und das läppert sich.
     
  2. Kelith Resident

    Kelith Resident Aktiver Nutzer

    Beiträge:
    318
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Schade, dass das Uploadfenster, in dem man das Mesh begutachten kann, nicht größer gemacht werden kann. Ich kann - sagen wir mal zu etwa 50% - Fehler im Mesh oder der Textur erkennen. Wenn das alles größer wäre, ginge das zu 100%.

    Im Betagrid ist das Hochladen wenigstens kostenlos. Und wenn ich merke, dass es dort schon zu Problemen kommt, lass ich das komplett und probiere es später noch mal. Zur Zeit klappt es im Betagrid wieder gut und dann klappt es auch für gewöhnlich im normalen Grid. Habe letztens auch mal einen Hausrohbau hochgeladen mit dem vollen Mesh als Physiklayer (das war testweise, normal würde ich ein vereinfachtes Physik-Mesh machen). Klappte tadellos. Tagesform von SL, würde ich sagen.
     
  3. JointVenture Resident

    JointVenture Resident Aktiver Nutzer

    Beiträge:
    101
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Blödsin. Sorry aber dein Fazit "Sucht nicht immer die Fehler bei euch...", nur weil du es nicht vernünftig machst und dich wunderst das nix klappt ist aus der Luft gegriffen.
    Nein, der upload macht keine unterschiedlichen Resultate. Ja, der upload ist kompliziert und braucht einige Einstellungen. Ohne, oder mit differenten Einstellungen hat mann natürlich Unterschiedliche Objekte.
    Wenn bei dem Upload einen Fehler zu sehen ist, ist der Fehler auch in SL zu sehen, und somit ein Fehler von dir. Entweder durch die exporteinstellungen von blend zu dae, oder schlicht ein Fehler in dem Meshobjekt, da hilft nur nacharbeiten, und auch alles andere, was du nicht gerne machst mal zu kontrollieren.
     
  4. argus Portal

    argus Portal Freund/in des Forums

    Beiträge:
    875
    Zustimmungen:
    5
    Punkte für Erfolge:
    18
    Blödsinn, was du da schreibst. Dir fehlt es an Erfahrung. Deine blinde Anbieterergebenheit ist wenig produktiv und Punkte bekommst du dafür auch nicht.

    Informationsgehalt deines Beitrags : 0, Stänkerpotential: Wesentlich über 0.
     
  5. eighthdwarf Checchinato

    eighthdwarf Checchinato Superstar

    Beiträge:
    4.715
    Zustimmungen:
    412
    Punkte für Erfolge:
    93
    Hmm Ich weiß nicht ob es hier mit reinpasst -- aber ich hab vor einiger Zeit mal ein Mesh-Gebäude-Pack gekauft, eins davon dann als künftigen Shop ausgewählt und gerezzt - aber als ich dann die Größe änderte (weil mich die 5+ Meter Raumhöhe genervt hatte, und um das Erdgeschoss an das des Nachbarhauses anzugleichen), konnte ich auf einmal nicht mehr in den Shop rein, trotzdem meine Avatare dank ihrer "realistischen" Primgröße nicht gerade riesig sind.
    Wenn ich einmal mit meinem Avi drin war, konnte ich zwar raus - aber reingehen konnte ich nicht. Auch nicht als ich es wieder auf die ursprünglichen Maße vergrößerte. Erst als ich das Haus löschte und eine andere Kopie hinstellte, und die Größe nur ganz minimal änderte, war es möglich.

    Was kann das verursacht haben? Hat Mesh auch eine Art Bounding-Box, die ich da durch das Verkleinern vermurkst hatte?
     
  6. Kelith Resident

    Kelith Resident Aktiver Nutzer

    Beiträge:
    318
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @eightdwarf: Hier stellt sich die Frage, ob man beim Ändern der Größe das Physik-Mesh mit ändert, oder ob dieses einfach in seiner Originalgröße verbleibt? Das wüsste ich mal gerne.
     
  7. argus Portal

    argus Portal Freund/in des Forums

    Beiträge:
    875
    Zustimmungen:
    5
    Punkte für Erfolge:
    18
    Ich habe es gerade einmal getestet. Eine einfache Türöffnung. Ich kann sie hin- und herskalieren; ich kann jederzeit hindurchgehen. Die Physik passt sch zumindest in dem Test immer der aktuellen Skalierung an.

    Dies Mesh ist so gross, das ich bequem hindurchgehen kann.


    Hier ist es in Blender. Sehr simpel also.

    Skaliertest.jpg
     
  8. Khufu Greymoon

    Khufu Greymoon Freund/in des Forums

    Beiträge:
    992
    Zustimmungen:
    163
    Punkte für Erfolge:
    53
    normal müsste sich der physikshape mit ändern, was man auf keinen fall machen solle ist auf vereinfachen gehen. damit hab ich mir so einiges kaputt gemacht.


    Edit/

    Kanns sein das sich das gebäude beim dehnen sich auf convexe hülle umgestellt hat eight? is mir auch schon passiert.
     
    Zuletzt bearbeitet: 13. April 2013
  9. JointVenture Resident

    JointVenture Resident Aktiver Nutzer

    Beiträge:
    101
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @ eightdwarf
    Das wird an der Berechnung für physische hülle liegen. Manchmal ist der Server etwas langsam, und es dauert einige Zeit bis die physik richtig dargestellt werden kann. lass dir die Physik über deinem viewer anzeigen. wenn du das bauteil rezzt siehst du die physik erst etwas später. Wenn das sehr große teile sind, kann das schon mal eine ewigkeit dauern.
     
  10. Raiser Nightfire

    Raiser Nightfire Aktiver Nutzer

    Beiträge:
    115
    Zustimmungen:
    0
    Punkte für Erfolge:
    16

    Ich hab das problem trotzdem ...

    mein türbogen besteht aus einem halbierten cube 0.375/0.875. ich habe mehrere physics gebaut und mit dem mesh kombiniert, keine analyse. trotzdem ist der türbogen nicht passierbar. auch eine umstellung auf prim bringt nix. je nach art des uploads kann ich gar nicht auf prim umstellen?


    ich muss das haus HEUTE liefern !!! hilfeee

    Gruß
    Raiser
     
    Zuletzt bearbeitet: 26. Mai 2013
  11. Dain Shan

    Dain Shan Aktiver Nutzer

    Beiträge:
    264
    Zustimmungen:
    55
    Punkte für Erfolge:
    28
    Da wir das Thema schon mal hatten ..
    Für welches Grid then? Second Life? Open Sim? Oder eines der anderen Grids?

    Meinst du den Cube in Blender? ( oder einem anderen Programm ) ?

    Ich poste hier nochmal die Lösung, die schonmal geklappt hat.

    [​IMG]

    Das gleiche hatte damals gut funktioniert, wenn es das war, was du meintest. Ansonsten bitte einen Screenshot einstellen, damit wir sehen können, um was es genau geht.
     
  12. argus Portal

    argus Portal Freund/in des Forums

    Beiträge:
    875
    Zustimmungen:
    5
    Punkte für Erfolge:
    18
    Oder lade das dae-File hoch.

    Zum Beispiel hier:

    http://www.file-upload.net/

    Dann kann man sich leichter ein Bild machen. Und wie hier schon gesagt wurde: Bitte das Ziel-Grid nennen.
     
  13. Raiser Nightfire

    Raiser Nightfire Aktiver Nutzer

    Beiträge:
    115
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    hallo und danke erstmal ...

    ich baue inworld und nutze mesh-studio. zum bauen firestorm, zum checken SL viewer ... den upload hab ich versucht, hoffe das klappt :

    http://www.file-upload.net/download-7637755/-R3GAURN.zip.html

    mittlerweile hab ich es in diesem fall so gemacht das ich den bogen neu aus 3 prims gebaut habe und das ganze auf konvex stelle.
    das klappt wenigstens und gibt nur 1 prim mehr. aber ich habe schon andere projekte gemesht und konnte dann immer auf prim stellen .. in diesem fall ging das nicht, die option fehlte einfach. zum glück ist es jetzt nicht mehr brandeilig.

    Raiser


    **** ICH FASSE ES NICHT *** HABE ZUM TEST MAL MEINEN EIGENEN LINK HOCHGELADEN ... und? geht! mesh zu prim stellbar und 1 prim zum durchgehen.
    so lief das vorher immer. da ich meine einstellungen normalerweise nicht ändere, frage ichmich echt woran das gehakt hat ???
     
    Zuletzt bearbeitet: 26. Mai 2013
  14. Khufu Greymoon

    Khufu Greymoon Freund/in des Forums

    Beiträge:
    992
    Zustimmungen:
    163
    Punkte für Erfolge:
    53
    Meshstudio is ne nette sache, ich nutz es auch, aber für die meisten sachen arbeite ich mittlerweile mit Sketchup.
    Es kann zwar lange nicht soviel wie Blender, aber meist reicht es völlig aus.
     
  15. argus Portal

    argus Portal Freund/in des Forums

    Beiträge:
    875
    Zustimmungen:
    5
    Punkte für Erfolge:
    18
    Ich habe es gerade getestet. Als ich eine einfache Form als Physikshape erstelle, diese dann mit "Triangulate" behandelte, inworld dann noch auf "Analyze" ging, funktionierte es tadellos. (Blender). (Ohne "Analyze" war die Tür nicht passierbar)


    Einerseits ist das, was du hier beobachtet hast, das es plötzlich funktioiniert, ohne das man etwas geändert hat,
    bekannt. Wie schon gesagt: So ganz ausgereift ist das nicht. Manchmal muss man mehrfach versuchen hochzuladen. Plötzlich geht es dann. Das ist insbesodnere dann angesagt, wenn man keine Fehler findet. Wenn man sich sicher ist, alles richtig gemacht zu haben.


    Dann noch etwas. Ich habe etwas mit deiner Tür experimentiert. Anscheinend kommt das System bei manchen, noch so simplen, Strkturen durcheinander: Bereits im Uploaddialog, dann auch nach dem Upload inworld, war plötzlich der Türdurchgang mit einer Fläche ausgefüllt. Die ist aber definitiv nicht da, sondern wird von der LL-Technik "hinzugezaubert". Ich hatte in Blender lediglich etwas mit limited-dissolve, triangulate usw. experimentiert.
     
  16. Kelith Resident

    Kelith Resident Aktiver Nutzer

    Beiträge:
    318
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Da ich gerade "Triangulate" lese: Blender V2.67(a) scheint ein Problem zu haben beim Collada Export. Normalerweise werden Flächen dabei in Dreiecke umgewandelt (Standardeinstellung). Bei NGons (Flächen mit mehr als 4 Eckpunkten) habe ich jetzt in der aktuellen Version bemerkt, dass dies fehlerhaft zu sein scheint. Es werden zwar Dreiecke erstellt, aber offenbar dazu wahllos Eckpunkte benutzt, so dass auch schon mal Öffnungen plötzlich mit einer Fläche verschlossen sind oder sich Dreiecke überlappen. Mache ich das "Triangulate" vorher im Edit Modus mit Strg+T selber und exportiere dann, ist alles OK. Exportiere ich das selbe Mesh mit Blender 2.66 und der automatischen Umwandlung der Dreiecke, ist auch alles OK.
     
  17. argus Portal

    argus Portal Freund/in des Forums

    Beiträge:
    875
    Zustimmungen:
    5
    Punkte für Erfolge:
    18
    Du hast recht, Kelith. Diesmal kann LL nichts dafür ;-) (Nur die Triangulate-Option hat nichts mit dem Problem zu tun)

    Hier mal zum nachvollziehen:

    1. Cube erstellen.

    2. duplizieren, etwas kleiner machen

    3. Cube aus Schritt 1 schmal skalieren

    4. Mit Cube aus Schritt 2 per Bool-Modifier ein Loch hineinschneiden.


    Den entstandenen "Rahmen" nach dae exportieren. Ob mit oder ohne Triangulate-Option
    spielt keine Rolle: Es sollte ok sein.


    Nun den Rahmen mit "Limited Dissolve" behandeln und exportieren.
    Wieder spielt die Triangulate-Option keine Rolle.

    Der Rest ist im Bild erklärt.

    Blenderproblem_beim_dae_export.jpg
     
  18. Kelith Resident

    Kelith Resident Aktiver Nutzer

    Beiträge:
    318
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Natürlich hat die Triangulate-Option mit dem Problem zu tun :) Vergiss die Option für diese Blenderversion einfach, wenn NGons im Mesh enthalten sind.

    In deinem ersten Versuch mit dem Rahmen hast Du nur quadratische Flächen, die sauber (durch die Automatik oder von SL) in Dreiecke gewandelt werden.
    In dem zweiten Versuch (limited dissolve) erzeugst du NGons. Dort klappt die automatische Triangulation nicht so wirklich. Daher das gefüllte Loch.
    Wenn man aber in Blender, vor dem Export, das Triangulate manuell macht, ist es sauber. Siehe Bilder unten:
    Unbenannt-1.jpg
     
  19. argus Portal

    argus Portal Freund/in des Forums

    Beiträge:
    875
    Zustimmungen:
    5
    Punkte für Erfolge:
    18

    Ob die Option aktiviert ist oder nicht, hatte hier nichts am Resultat geändert. Das meinte ich.
     
  20. Raiser Nightfire

    Raiser Nightfire Aktiver Nutzer

    Beiträge:
    115
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    :bahnhof :thumbup

    raiser