1. Bitte schaltet eure Ad Blocker aus. SLinfo kann nur betrieben werden, wenn es durch Werbung Einnahmen erzielt. Vielen Dank!!
    Information ausblenden
  2. Wir freuen uns, wenn du dich in unserem Forum anmeldest. Bitte beachte, dass die Freigabe per Hand durchgeführt wird (Schutz vor Spammer). Damit kann die Freigabe bis zu 24 Stunden dauern.
    Information ausblenden
  3. Wir verwenden Cookies, um Inhalte und Anzeigen zu personalisieren, Funktionen für soziale Medien anbieten zu können und die Zugriffe auf unsere Website zu analysieren. Sie geben Einwilligung zu unseren Cookies, wenn Sie unsere Webseite weiterhin nutzen.
    Information ausblenden

AO funktioniert nicht beim Detachen

Dieses Thema im Forum "Ich frage - ihr antwortet!" wurde erstellt von Niani Resident, 9. Januar 2018.

  1. Daemonika Nightfire

    Daemonika Nightfire Forumsgott/göttin

    Beiträge:
    7.381
    Zustimmungen:
    423
    Punkte für Erfolge:
    93
    Interessant, die Viewer Site AO spinnt also auch hin und wieder?
    So langsam beschleicht mich der Verdacht, das es nicht an den AOs selber liegt, sondern ehr an der jeweiligen Internet Leitung bzw Auslastung der Bandbreite.
    Vermutlich arbeiten die AOs weiterhin einwandfrei, doch ihr koennt es nicht sehen, weil der Viewer irgend welche Informationen nicht bekommt.
    Schaut mal bei gelegenheit auf euren Packet Verlust (packetloss) wenn die AO mal wieder spinnt.
    Vielleicht auch andere anwesende fragen, ob die das ebenfalls so sehen, was ihr in dem moment seht.

    LG
    Dae
     
    Zuletzt bearbeitet: 11. Januar 2018
  2. Leonorah Beverly

    Leonorah Beverly Superstar

    Beiträge:
    2.413
    Zustimmungen:
    4.345
    Punkte für Erfolge:
    123
    Meine Gedanken wandern inzwischen in Richtung Vista.
    Sowohl im Akeyo-HUD wie auch im ungeliebten Firestorm-AO habe ich nämlich Vista-Stands drinnen. Das ist so ziemlich die einzige Gemeinsamkeit der beiden AOs.
    Niani hat Vista, Kitten hat Vista, Lucky hat Vista, ich auch ...
    Sonst noch jemand?
     
  3. Daemonika Nightfire

    Daemonika Nightfire Forumsgott/göttin

    Beiträge:
    7.381
    Zustimmungen:
    423
    Punkte für Erfolge:
    93
    Ich verwende zu 90% Vista Animationen und kann den Fehler immer noch nicht reproduzieren.

    LG
    Dae
     
  4. Daemonika Nightfire

    Daemonika Nightfire Forumsgott/göttin

    Beiträge:
    7.381
    Zustimmungen:
    423
    Punkte für Erfolge:
    93
    So eben faellt mir noch etwas ein.
    Ich komme dabei noch mal auf das beispiel mit den beschissenen Fluegeln zurueck, die Server Site Animation triggern, auch wenn der Ersteller das gegenteil behauptet.
    Am Avatar kann ausschliesslich einmal fuer jeden State eine Server Site Animation gesetzt werden. Ab dem zeitpunkt wuerden konventionelle AOs die nach den einzelnen Namen der Anim States fragen, nicht mehr funktionieren, weil der Name auf dem Server nicht mehr stimmt.
    Die einzige Animation bzw. 2 Anis lassen sich weiterhin per Script tzriggern, die da waeren Sit und Sit on Ground. Das hat Linden Lab explizit beruecksichtigt, da zig millionen Moebel in SL nicht mehr funktionieren wuerden, wenn die Animationen mit Server Site Anis ersetzt werden.

    Nun zum vermutlichen Problem.
    Koennte es sein, das wie ich diese bei den dubiosen Fluegeln ploetzlich Noob-Walk hatte, das ihr ebenfalls aehnliche Attachments verwendet, die Sever Site Animationen setzen? (Bento Haende, Bento Kopf, Bento Fluegel, Bento Schwanz, Bento zweitzes Paar Beine (Vierbeiner Avatar), halt alles was neben einer AO animationen ausloest.)
    Denn da koennte der Fehler liegen.

    Kurze Erklaerung:
    Bento Attachments koennen ausschliesslich mit Bento Animationen animiert werden.
    • bewegliche Fluegel = Animation
    • bewegliche Schwanz = Animation
    • bewegliche Finger = Animation
    • animiertes Gesicht = Animation
    • zusaetzliche Beine = Animation

    LG
    Dae
     
    Zuletzt bearbeitet: 11. Januar 2018
  5. Leonorah Beverly

    Leonorah Beverly Superstar

    Beiträge:
    2.413
    Zustimmungen:
    4.345
    Punkte für Erfolge:
    123
    Bento-Hände mit den automatischen Anis des Maitreya-HUDs.
    Bis vor einer Weile hatte ich auch am Bento-Kopf eine Ani laufen, die mich aber so genervt hat, dass ich sie deaktiviert habe. DAMALS war mir kein Fehler am AO aufgefallen.
     
  6. Daemonika Nightfire

    Daemonika Nightfire Forumsgott/göttin

    Beiträge:
    7.381
    Zustimmungen:
    423
    Punkte für Erfolge:
    93
    Maitreya setzt die Animationen nicht Server Site, die faellt schon mal weg.
    Es sollten Attachments sein, die euern Status abfragen muessen um zu reagieren, damit es nicht bescheuert aussieht.
    Fluegel sollten schwingen beim fliegen.
    Schwaenze sollten zur seite gehen beim setzen.
    Beine sollten laufen beim laufen.
    Alles in allem, animationen die auf eure Bewegungen reagieren muessen.
    Keine zufaelligen Animationen fuers Gesicht oder Haende, da macht es naemlich keinen Sinn die auf Server Site zu triggern.

    Worauf ich hinaus will ist, vielleicht hat wieder mal ein Ersteller bestimmter Attachments Mist gebaut und den Befehl llSetAnimationOverride anstelle von llStartAnimation welche voellig ausreichen wuerde, in seinen Scripten verwendet.

    LG
    Dae
     
  7. Marian Dufaux

    Marian Dufaux Aktiver Nutzer

    Beiträge:
    331
    Zustimmungen:
    256
    Punkte für Erfolge:
    63
    Ich habe keine Vista - AO.
     
  8. Niani Resident

    Niani Resident Freund/in des Forums

    Beiträge:
    880
    Zustimmungen:
    1.479
    Punkte für Erfolge:
    104
    Ich nutze selten die Animationen, die Bento bietet (ab und zu nur die Hände, aber das Gewackel geht mir auch auf den Zwirn).

    Gestern wieder ein Beispiel:
    Ich habe mir ein Kleidungsstück angezogen und es über einen HUD umgefärbt. Als ich den HUD abgenommen habe, funktionierte auch
    mein AO nicht mehr und ich musste ihn zuerst deaktivieren und dann wieder aktivieren, bevor die Animationen liefen.

    So geht das ständig :-(
     
  9. Khufu Greymoon

    Khufu Greymoon Superstar

    Beiträge:
    1.211
    Zustimmungen:
    404
    Punkte für Erfolge:
    93
    Meine Animationen sind von bodyLanguage, also fällt Vista da auch raus. Bento sind nur die Hände und die fallen ebenfalls raus weil Maitreya.
    Ich achte die letzte zeit mehr darauf und das Problem findet sich, zumindest bei mir, bei fast allen Attachments die nur kurzzeitig angelegt werden also auch bei Paketen, Taschen und sonstigen Verpackungen die angelegt werden um sie zu öffnen
     
  10. Daemonika Nightfire

    Daemonika Nightfire Forumsgott/göttin

    Beiträge:
    7.381
    Zustimmungen:
    423
    Punkte für Erfolge:
    93
    Bietet der HUD zum Faerben zufaellig eine Option fuer eine Pose zum anpassen am Avatar an?
    Es gibt auch Kleider (lange Kleider) die eine eingebaute Animation besitzen, damit man nicht zu grosse Schritte beim gehen macht. Wieder eine AO die stoeren koennte.
    Alles was euch animeiren will, benoetigt eine Erlaubniss euch animieren zu duerfen, nun haben wir folgendes Problem, als Owner wird die Permission automatisch beim tragen erteilt.
    Beim rezzen oder als Nicht-Owner wird man gefragt, ob man animiert werden darf. Das ist noch nicht weiter Schlimm. Spannend wird es, wenn der jeweilige Scripter beim detachen/abnehmen daran gedacht hat, die Permission wieder zu entziehen. Wenn das aber nicht sauber programmiert wird, entzieht man allen Objecten die aktuell laufen die Permission euch zu animieren. In dem Fall auch der AO und man muss sie wieder neustarten.

    LG
    Dae
     
    Zuletzt bearbeitet: 12. Januar 2018
  11. Niani Resident

    Niani Resident Freund/in des Forums

    Beiträge:
    880
    Zustimmungen:
    1.479
    Punkte für Erfolge:
    104
    Nein, Daemonika. Das Phänomen tritt ja nicht nur dabei auf. Egal, was ich vom Body detache: Der AO geht aus.
     
  12. Lucky Bekkers

    Lucky Bekkers Forumsgott/göttin

    Beiträge:
    6.263
    Zustimmungen:
    2.394
    Punkte für Erfolge:
    114
    Wenn ich aber die Animation per Hand aus dem Inventar ("inworld abspielen") steuere, dann läuft - einmal aktiviert - sie kontinuierlich weiter.
    Allerdings muss ich dann natürlich wenn ich einen andere Ani haben möchte die lfd. stoppen und die neu dann wieder per Hand aktivieren.
     

Diese Seite empfehlen

  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deinem Erleben anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden